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Overview

National Instruments (NI) allows users to integrate third-party EtherCAT servo drives into their real-time
controller platform using the SoftMotion Drive Interface (SDI). This interface consists conceptually of a
framework and a plugin as shown in Figure 1.

Figure 1 The SoftMotion Drive Interface consists of a framework and a plugin. The framework is supplied by National
Instruments and is common to all SDI implementations, while the plugin is supplied by the drive manufacture and is unique to
each drive type. The Bosch Rexroth SDI plugin may be downloaded from the LabVIEW Tools Network.

SDI effectively acts as a bridge between the LabVIEW SoftMotion trajectory planner and the IndraDrive
servo drive. From the user’s point of view, it allows native LabVIEW motion commands to be used
directly with the Bosch Rexroth drive hardware. Note that this configuration takes full advantage of the
real-time capabilities of the EtherCAT bus.
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Figure 2 System architecture features the compactRIO (“cRIO”) real-time controller from NI together with the Bosch Rexroth
IndraDrive Cs. EtherCAT CoE is used as the real-time industrial bus.

1.1

Hardware requirements

National Instruments real-time controller: NI models cRIO 9064, cRIO 9022, cRIO 9033 and cRIO 9039
have been tested internally, but additional options from NI may be available. Contact National
Instruments for more information. At a minimum, the controller must have a network adapter that can be
configured as an EtherCAT master and the controller must support the LabVIEW SoftMotion and realtime modules.
Servo drive: Bosch Rexroth IndraDrive C or IndraDrive Cs drives that support EtherCAT CoE may be
used. Additional options include IndraDrive ML and IndraDrive Mi 1. In all cases, firmware version MPx20V10 or higher is required. For commissioning purposes, it is recommended to purchase the additional
engineering port (X26) option. This is identified in the type code as the EP option. For clarity this
document will focus on IndraDrive Cs. Configuration of the other drive options is similar.
Servo motor: Bosch Rexroth offers MSK, MS2N and MSM series servo motors as standard options, as
well as a wide variety of linear and kit motors. In most cases, third-party motors may also be used
provided a suitable position feedback device is available. Contact your Bosch Rexroth representative or
see our website2 for more information.

1

IndraDrive ML supports power output up to 4 MW. IndraDrive Mi integrates drive and motor in a single package.
Note that IndraDrive Mi does not support the EP option.
2 www.boschrexroth.com/indradrive
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Figure 3 Bosch Rexroth offers a wide selection of synchronous, asynchronous, linear and kit motors. The range of the IndraDrive
servo family extends from 50 W up to 4 MW.
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Software requirements


IndraWorks Ds 14v14 or higher









NI LabVIEW 2015 f2 or higher
NI Real-Time Module
NI FPGA Module
NI SoftMotion Module
NI Industrial Communications for EtherCAT
NI-RIO Drivers
NI Application Builder (recommended)

Figure 4 shows a typical installation of LabVIEW, with the required additional software packages
highlighted.

Figure 4 National Instruments Measurement and Automation Explorer (MAX) provides a listing of the currently installed NI
software.
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SDI Plugin installation

Preferred method via VI Package Manager:
It is recommended to install the SDI plugin using the JKI VI Package Manager (VIPM). This free software
is available on National Instruments' website, but may also be downloaded directly from JKI:
https://vipm.jki.net/
To install the plugin, launch VIPM, select the LabVIEW version, then, in the list of available add-ons, rightclick on “SDI Plugin – Bosch Rexroth IndraDrive” and select Install. Note that installation will be finalized
only after the user accepts the end-user license agreement (EULA).

Figure 5 VIPM is the preferred method of installing the Bosch Rexroth SDI plugin.
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After successful installation, SDI Plugin-Bosch Rexroth IndraDrive will be listed under the installed addons:

Figure 6 The JKI VI Package Manager may be used to verify that the SDI plugin has been installed.

Note that if online access to the NI LabVIEW Tools Network Repository is not possible, VIPM still may be
used to install the plugin provided the required VI package file 3 is available locally. In this case, launch
VIPM and select File>Open Package File(s). Navigate to the required VI package and click OK. Follow
the wizard to complete the installation process.

Alternate manual method:
If JKI VI Package Manger itself is not available, it is still possible to install the SDI plugin manually.
Contact your Bosch Rexroth representative for the required files.
The SDI plugin consists of a set of virtual instruments (VIs) and a device description file. Copy the files
provided to the LabVIEW installation folder as follows:
1. Add the SDI plugin VI and class files to folder <LabVIEW>\vi.lib\Motion\plugins\BoschRexroth
IndraDrive Plugin, where <LabVIEW> represents the particular installation of LabVIEW.

3

Current SDI plugin version: sdi_plug_in_bosch_rexroth_indradrive-1.0.1.3.vip.
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On a typical 32-bit LabVIEW installation, the resulting configuration would look like this:

Figure 7 Adding the SDI plugin VIs to the LabVIEW installation. Note that the user may have to manually create folder
BoschRexroth IndraDrive Plugin.

2. Add the device description file named “BoschRexroth_IndraDrive_CoE_NI.xml” to folder
<LabVIEW>\resource\Framework\Providers\indcomecat\DD

Correct configuration of the device description file on a typical 32-bit LabVIEW installation is shown
below.

Figure 8 Adding the SDI plugin device description file to the LabVIEW installation.

Once the SDI plugin is installed correctly, the plugin specific VIs will be available in the block diagram
palette under Addons>BoschRexroth_IndraDrive_PluginAxis.

Figure 9 The Bosch Rexroth SDI plugin consists of two public VIs: Open and nismSDIFramework. Their use is discussed in later
sections.
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Connecting to the cRIO control

When available, cRIO’s USB Type B interface provides the easiest method of carrying out the initial
device configuration. First, make sure NI Device Monitor is running on the host PC:

Figure 10 NI Device Monitor may be launched from the Windows Start menu.

Next, after attaching a USB A/B cable from the host PC to the cRIO control, NI Device Monitor will
indicate that a device has been recognized by showing the following dialog:

Selecting “Configure and install software to this device>Go” will launch NI Measurement & Automation
Explorer (“NI MAX”), with the device listed under remote systems:
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Figure 11 Connected devices are shown in NI MAX under Remote Systems.

At this point the user is ready to install the necessary software to the device and to configure the network
adapters. These points will be discussed in the next sections.
If the USB Type B interface is not available on the cRIO control, and the IP address of device is not
known, then it may be required to reset the network adapters to their factory default settings. See the
device or user manual provided by National Instruments for more information. By default, any network
adapters will accept an address provided by a DHCP server. If this is not available, the device will
connect to the network using a link-local IP address of the form 169.254.xxx.xxx. Once a network
connection to the device is established, launch NI MAX and verify that the device is shown under Remote
Systems as described before. See Figure 11.
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Configuring the Ethernet adapters

Here we assume that a connection to the cRIO device has been made as described in the previous
section. In particular, we assume that NI MAX is running and the device is listed under Remote Systems.
To configure the Ethernet adapters of the cRIO control, select the device under Remote Systems and
click on the tab labeled “Network Settings.”

Figure 12 Ethernet adapters may be configured in NI MAX under Network Settings.

Configure the primary Ethernet adapter with the desired network settings. The primary adapter will be
used for commissioning and programming activities. Set the secondary Ethernet adapter to adapter
mode “EtherCAT”.
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Software updates

NI MAX is also used to configure the system software running on the cRIO control. Under Remote
Systems, click the triangle to the left of the device so that the subitems are visible. Right-click on
Software and click Add/Remove Software.

Figure 13 Use NI MAX to install software to the connected device.

National Instruments will recommend a list of software modules to install (a “software set”). In addition to
the standard software set, be sure to include the following addons:
LabVIEW SoftMotion Module, NI-RIO IO Scan, NI Industrial Communications for EtherCAT.
These options are shown in Figure 14.

Figure 14 The Bosch Rexroth SDI plugin requires that the connected device software include the add-ons shown.
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After completing the installation wizard, the active device software will be shown in the device tree. The
figure below shows a typical installation.

Figure 15 The software currently installed on a connected device may be viewed in the NI MAX project tree under Remote
Systems.
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IndraDrive Cs commissioning

IndraWorks Ds is free software that may be used to commission the IndraDrive Cs. It is available for
download at www.boschrexroth.com/indradrive. Note that IndraWorks Ds version 14V14 or later is
required.
3.1

Physical connections

The connections points for the IndraDrive Cs (Economy and Basic versions) are shown in Figure 164.
Optional interfaces are indicated with an asterisk (*).

A
B
C
D
E
X3
X4
X5
X6
X8

Equipment grounding point, mains
Equipment grounding point, motor
Control line shield
Motor cable shield
Display panel
Mains
Motor encoder
Motor power
Motor temperature + holding brake*
Secondary encoder* (EC option) or
encoder emulation* (EM option)
X9
Braking resistor
X13
+24 VDC
X24, X25 CANopen over EtherCAT (CoE)**
X26
Engineering* (EP option)
X30
PROFIBUS* (PB option)
X31
Digital inputs, digital outputs
X32
Analog input
X37
Digital I/O* (DA option)
X38
Analog I/O* (DA option)
X41-X43 Safety technology* (S4, S5 options)
X47
Bb contact
X49
Safety technology* (L3, L4 options)
X61
CANopen* (CN option)
X77
DC bus*

* optional
** assumed user-configuration

Figure 16 Standard and optional interfaces for IndraDrive Cs.

4

IndraDrive Cs (Advanced) is similar, but in that case the CANopen over EtherCAT ports are labelled X22, X23.
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Connecting to the drive

Using an Ethernet cable, connect your host PC to the engineering port (X26) on the IndraDrive Cs.
Launch IndraWorks Ds. The following dialog screen should appear:

Figure 17 "Network search" allows the user to search for any connected IndraDrive devices.

Option 1. From the tab labeled “Network search,” select the appropriate network adapter from the
dropdown and click Browse. Irrespective of the local LAN settings (provided that some TCP/IPv4 address
has been assigned), the software will browse the network for drive instances. Any drives discovered on
the network will be listed according to network address. Select the desired drive by checking the box in
the Connect column. Connect to the drive by clicking OK.
If the chosen network adapter and the IndraDrive Cs are not on a common subnet, IndraWorks Ds will
ask whether the IP settings of this adapter should be extended so that a connection can be made:
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Figure 18 IndraWorks Ds will extend the network adapter settings so that a connection to a device not on the local subnet may
be made.

Connect to the drive by clicking “Extend IP Address Settings Now.”

Option 2. The IP address of the X26 port is may be obtained (or edited) from the front panel of the drive
of the drive. The required key sequence is shown below.

Figure 19 Depiction of IndraDrive Cs front panel. Use the Esc and Enter keys to navigate through the menus. Once an editable
item in the menu is reached, press Enter to edit or Esc to cancel. Use the up and down arrow keys to change selected values.
See the IndraDrive Cs documentation for more information.
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Use the Enter and Escape keys to navigate through the various menus. Use the up and down arrow keys
to edit the individual fields or select individual menu items. If the IP address is changed, the new address
does not take effect until the drive is rebooted.
Once the IP address of the X26 port is known, adjust the settings of the local network adapter so that the
two devices are on the same subnet.

From the tab labeled “IP address search,” enter the drive’s IP address or a range within which the IP
address occurs, then click Browse. As in option 1, if the drive is recognized on the network, it will be
listed in the main list box. Select the desired drive by checking the box in the Connect column and
clicking OK.

Figure 20 "IP address search" allows users to browse for IndraDrive devices within a specified address range.
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Loading base parameters

The drive may be reset to its default settings by selecting Commissioning>Load basic parameters from
the main menu. In the resulting dialog, select the desired options and click “Close.” Resetting the
parameters to their default settings is typically only required if the drive has been used previously.

Figure 21 Use the “Load Basic Parameters” dialog in IndraWorks Ds to reset the drive to its default settings.
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Setting the master communication

For use with the cRIO control, the multi-protocol, real-time communication ports (typ. X24/X25) of the
IndraDrive must be configured to use the CANopen over EtherCAT protocol.
From the explorer panel on the left, select Master Communication. In the associated dialog, set the
Active protocol to “CAN Application Protocol over EtherCAT (CoE).” Confirm that the drive profile should
be set to “CiA 402.” Changes to the master communication will take effect only after the drive is
rebooted.

Figure 22 Use the Master Communication dialog in IndraWorks Ds to activate the CANopen over EtherCAT protocol. The CiA
402 drive profile must be used.
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After rebooting the drive, the active drive profile may be verified under Axis>Master
Communication>Settings:

Figure 23 The active CoE configuration may be viewed in IndraWorks Ds under Master Communications>Settings. The SDI
plugin requires that the CiA 402 drive profile be used.
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Configuring the drive scaling

IndraDrive Cs allows the user to scale the drive freely per the requirements of the application. Typically
this means that the drive position refers to the actual position of the driven load in appropriate units. If the
load is rotating, the drive is scaled in degrees. If the load is moving linearly, the drive is scaled in
millimeters. Any gearing between the motor and the load must be accounted for. In the linear case, the
feed constant (i.e. the amount of linear travel per revolution input) must also be defined.
In IndraWorks Ds, use dialog Mechanical Axis System/ Scaling to configure the drive as required.

Note that when using IndraDrive with the SDI plugin, the position data format type Absolute is preferred,
as data rollover is handled by SoftMotion. Also, the maximum travel range (S-0-0278.0.0 / 0x2116 01) is
determined by SoftMotion; user configuration of this parameter is lost whenever SoftMotion activates the
Scan Engine.
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Configuring the I/O

With reference to Figure 16, the X31 interface of IndraDrive Cs supports 7 digital input pins plus 1
additional pin that may be configured as an input or output. The SDI plugin provides minimal support for
this interface. The supported input types are shown in IndraWorks DS> I/O X31/X32.

Figure 24 The SDI plugin supports hard travel limit switches, a home switch, as well as a single high-speed probe capture input.

The travel limit inputs, as well as the home switch input, may be landed on any of the 8 pins. If used,
probe input 1 must be landed on pin 1 or pin 2. All inputs are optional.
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Configuring the touch probe

IndraDrive Cs supports high-speed capture of the motor position on the rising edge of the probe 1 input.
See Figure 24 of the previous section for the required digital input configuration. High-speed capture of
the internal system clock or a secondary encoder is also possible. To configure the capture settings, in
IndraWorks Ds, see the dialog labeled Probe. A typical configuration is shown in Figure 25.

Figure 25 Use the Probe dialog in IndraWorks Ds to configure the high-speed capture of the selected signal. Data capture is
triggered by the rising or falling edge of the digital input configured as “Probe 1”.
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Creating a blank LabVIEW project

To create a blank LabVIEW project, launch LabVIEW and double-click Blank Project from the list of
Recent Project Templates5.

Figure 26 Use LabVIEW's launch page to create a Blank Project or open previously created projects.

4.1

Inserting a controller into a LabVIEW project

Once the blank project is created, the controller may be added to the project by selecting New>Targets
and Devices from the context menu of the main node in the project tree. In the resulting dialog box,
select your device from the list of available devices, then click OK. Note that the devices are listed
according to type, and the discovery process is only launched once the type is expanded. Know your
device type! When prompted by the wizard, define the programming mode as Scan Interface.

5

Note that clicking the button labeled Create Project will open a template wizard. Here the user may leverage nontrivial (i.e. not blank) templates, including templates for state machines and SoftMotion. Where applicable, use of
these templates is strongly encouraged.
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Figure 27 Inserting the NI real-time controller.

4.2

Adding the EtherCAT master to the project, and scanning for any slaves

Next we add the EtherCAT master to the system together with any connected IndraDrive Cs devices.
First, ensure that each drive is powered and configured to use CAN over EtherCAT as the method of
master communication. Next, use Ethernet CAT 5e (or better) cabling to create a daisy chain from the
EtherCAT master port (eth1) to each slave. Note that on IndraDrive Cs, the bottom port (typ. X25) is the
input and the top port (typ. X24) is the output. Figure 2 gives a typical configuration.
From the controller’s context menu, select New>Targets and Devices… In the dialog that appears,
expand folder EtherCAT Master Device and select the adapter shown. Click OK.

Figure 28 Adding the EtherCAT master to the project.
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As a result, the EtherCAT Master will be added to the project along with any discovered slave devices.
Notice that the device addresses are automatically assigned according to the topological order and do not
correspond to any Sercos addresses that may have been preassigned by the user.

If desired, the user may rename the devices. To do this, right-click on the device in question and select
Rename.

Figure 29 EtherCAT slave devices may be renamed using the associated context menu.

Introduction to the NI SoftMotion Drive Interface for IndraDrive

4.3

Bosch Rexroth AG

Page 29 of 51

Distributed Clock

Each EtherCAT slave device corresponding to an IndraDrive C or IndraDrive Cs should have its
distributed clock enabled as shown in Figure 30. Users will find this setting on the Properties page for
each device listed under the EtherCAT master. In addition, SYNC 1 must be enabled. The default values
for cycle time=1 and shift time=0 may be used.
All other default values for the EtherCAT slave properties are acceptable and need not be altered. For
reference, these default values are listed below.


EtherCAT Advanced Mailbox

Mailbox Poll Period (scan periods) = 1



EtherCAT Advanced Watchdog

Sync Manager Watchdog = Enabled
Timeout = 1000 x 100 us



EtherCAT Advanced Initial Commands

No initial commands required

Figure 30 IndraDrive Cs must be configured with the distributed clock and SYNC1 options enabled as shown.
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Adding SoftMotion axes

NI SoftMotion does not issue instructions to an EtherCAT servo device directly, but rather to an
intermediary software object known as a SoftMotion axis. This means that to each of the EtherCAT
slaves listed under the EtherCAT master, we must assign a SoftMotion axis.
To do this, right-click the controller in the project tree and select New>SoftMotion Axis…

In resulting Axis Manager dialog, use the Add New Axis button to add a SoftMotion axis to the project.
The system will choose a slave device to be associated or “bound” to the new axis. If the default binding
is incorrect or unintended, click the Change Binding button and reassign the hardware using the
Resource Binding dialog.

SoftMotion axes will be listed in the project tree as shown in Figure 31. Note that additional simulated
(i.e. “unbound” or not associated to hardware) axes may also be added. Such axes may be useful in
particular as virtual masters in gearing or camming applications.
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Figure 31 SoftMotion axes are listed in the LabVIEW project tree together with their associated EtherCAT devices.

4.5

SoftMotion axis configuration

Refer to NI documentation or the LabVIEW online help for a complete description of the SoftMotion axis
functionality. Here we only note one critical aspect of the configuration. Selecting Properties from the
context menu of a SoftMotion axis opens the Axis Configuration dialog. Referring to Figure 33, click on
Encoder to scale the position or “feedback” of the SoftMotion axis. The user may scale the axis as
required, but if the IndraDrive Cs is scaled in rotary degree units with the default position resolution, then
it would be customary to define Units as ‘deg’ or ‘degree’ and to set the number of Counts per deg to
1000.

Figure 32 In IndraWorks Ds, the extended scaling parameterization of the IndraDrive Cs is shown. Here, Exponent = -3 indicates
that the rotary position will be resolved to the nearest 1/1000 degree. (N.B. 1/1000 = 10-3)
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Deploying the project configuration

Once the EtherCAT master and slave devices have been added to the project, as well as the associated
SoftMotion axes, the project configuration may be deployed to the control. To do this, right-click on the
cRIO controller in the project tree and select Deploy All.

Note that if EtherCAT slave devices are physically added or removed, the project configuration must be
altered accordingly and re-deployed.

4.7

Scan Engine

The NI documentation describes the Scan Engine as follows:
The NI Scan Engine enables efficient single-point access to sets of data channels, such as I/O
channels, using a scan that stores data in a global memory map and updates all values at a single
rate, known as the scan period6.
All real-time EtherCAT processing done by the controller happens within the context of the Scan Engine.
Real-time processing does not occur until the Scan Engine has been switched to its Active state. Users
may set the states of the Scan Engine (Active, Configuration) using the tool provided in the Utilities menu.
However, switching of the Scan Engine is typically handled programmatically using the
nismSDIFramework VI within the Bosch Rexroth SDI add-on. See Section X.X.
As the Scan Engine switches from Configuration to Active, the EtherCAT master will attempt to complete
its phase run-up (Pre-operational -> Bootstrap -> Safe Operational -> Operational). In addition, as
directed by the EtherCAT master, each IndraDrive Cs device will attempt to switch from Parameter Mode
to Operation Mode.

National Instruments: Using the NI Scan Engine (Real-Time, Windows) (6/2013),
http://zone.ni.com/reference/en-XX/help/371361K-01/lvioscanhelp/scan_engine/
6
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Setting the Scan Period

The Properties page of the cRIO controller allows the user to set the period of the Scan Engine. This
value corresponds directly to the update rate of the EtherCAT bus. Scan Periods of 1 ms, 2 ms and 10
ms have been tested. Generally, a lower Scan Period will improve servo motor performance. However,
systems with high axis counts - because of the corresponding higher network traffic - may require a larger
Scan Period.
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General approach to modifying NI sample code for use with SDI plugin

The NI sample code provided in their NI Example Finder tool may be easily modified for use with the SDI
plugin. To launch NI Example Finder, in LabVIEW select Help>Find Examples from the main menu.
In particular, see the sample code found in NI Example Finder>Toolkits and Modules>SoftMotion>
Express VIs.
An example of how to modify the sample code is shown in the next two figures. Figure 34 shows the
original code, in this case Power.vi. Figure 35 shows modified version.

Figure 34 Original sample code: Power.vi. National Instruments provides many samples such as this in their NI Example Finder
library.

Figure 35 Power.vi edited to include the SDI plugin. Modified code is boxed in orange.

With regard to the required modifications, we note the following:


The SoftMotion axis resource must be tied to the SDI plugin using the Open VI found on the
Block Diagram palette under Addons>BoschRexroth_IndraDrive_PluginAxis 7.

A separate instance of Open.vi is required for each SoftMotion axis.


7

Next, transition the Scan Engine to Active Mode using the nismSDIFramework.SetFrame method.
This is standard NI code, but for convenience may be found on the

In all figures that follow, a purple flowline refers to a SoftMotion resource, while a yellow flowline refers to the
standard error path. To simplify the figures these flowlines will not be labelled.
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BoschRexroth_IndraDrive_PluginAxis palette. (Its standard location is on the Block Diagram
pallet under Vision and Motion>NI SoftMotion>Advanced>Set Mode.)



5.1

Finally, upon exiting the application, return the Scan Engine to Configuration Mode using a
second call to nismSDIFramework.SetFrame, this time with the transition target defined as
Configuration Mode.

SoftMotion palette

Subsequent sections introduce some of the basic functionality provided by the SoftMotion palette. This
functionality is not specific to the Bosch Rexroth SDI plugin and is included here for convenience only.
See the relevant NI documentation for more information.

Figure 36 The Bosch Rexroth SDI plugin supports VIs found on the SoftMotion palette. On the Block Diagram workspace, see
Vision and Motion>NI SoftMotion>Express.
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Reading and clearing faults

The error status of the IndraDrive Cs may be monitored using the Read.vi from the SoftMotion palette.

Make sure the selected method is set as Status and the Input/Output type is selected as fault occurred.
Similarly, the Read VI may be configured to read the fault code of the IndraDrive Cs by selecting method
Faults.

Figure 37 IndraWorks Ds and LabVIEW state after triggering positive travel range limit fault.

If a drive fault has occurred, the user may clear it by calling the Clear Faults VI:
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Hint: If a drive error does occur, further information may be found in the IndraWorks Ds help files. See
IndraWorks Ds>Help>Drive Help>INDR*-MPx-20VRS. Note that all drives faults are referenced internally
using format FXXXX.

Figure 38 The IndraWorks Ds help files include fault-specific information, troubleshooting tips, as well as general information.
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Power

Use the Power VI from the SoftMotion palette to energize the motor.

Note that there are separate inputs for enabling the axis (i.e. the SoftMotion object) and for enabling the
physical servo drive. The SoftMotion axis may be enabled without enabling the drive (the converse is not
true), but in practice these are usually enabled (or disabled) together simultaneously.
To disable the drive (i.e. de-energize the motor), call Power with enable drive = false.

To monitor whether the drive is enabled, use the Read VI with the Method selected as Status and the
Input/Output type set to drive enabled. Note that the status of the SoftMotion axis may also be monitored
using the Input/Output type set to axis enabled.

The drive may only be enabled if it is in an error-free state. Users may want to proceed all calls to
Power(enable axis = true, enable drive = true) with a call to Clear Faults as a matter of course.
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Position moves

SoftMotion supports absolute or relative position moves using the Straight-Line Move VI. Select method
“Absolute” or “Relative” as appropriate. In addition to the position target, the motion trajectory may be
adjusted using inputs velocity, acceleration, deceleration, accel. jerk, decel. jerk and smoothing.

Energize the servo motor using the Power VI prior to initiating a straight-line move.

Figure 39 IndraWorks Ds oscilloscope showing axis trajectory when commanded to move to an absolute position of 1000 deg.
Note that axis position is automatically set to position 0 after transitioning to Ab and that an absolute move does not require
that the drive’s reference position has been established.
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The current motor position may be read using the Read VI with the Method select as Data and the
Input/Output type set to position.

5.5

Velocity moves

To move the motor at a constant speed, use the Straight-Line Move as before, but with the method
selected as Velocity. Inputs for acceleration, deceleration, accel. jerk, decel. jerk and smoothing are also
available.

The current motor velocity may be read using the Read VI with the Method select as Data and the
Input/Output type set to velocity8.

8

Note that Read VI supports multiple input/outputs. Users may read, for example, motor position and velocity in a
single call. Here we show a single block output for clarity only.
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Write setpoint

The commanded position, velocity or torque setpoints may be written to directly using the Write VI. The
three variants are shown below9.

When using any of these variants, be sure to provide setpoint updates within a timed loop synchronized
to the Scan Engine. Within the timed-loop, memory allocation should be kept to a minimum. This will
reduce jitter and improve performance.
The timed-loop structure is found on the Block Diagram under Structures>Times Structures. Once the
loop is added to the VI, open the Configure Timed Loop dialog and set the internal timing source type to
Synchronize to Scan Engine.

In a sense these are mutually exclusive: If you are writing to one of the setpoints, don’t write to either of the other
two.
9

Introduction to the NI SoftMotion Drive Interface for IndraDrive

Bosch Rexroth AG

Page 43 of 51

Figure 40 Write>velocity setpoint may be used to pipe real-time velocity commands to the IndraDrive Cs. Above is the calculated
velocity trajectory. Below is the actual velocity output, shown in the IndraWorks Ds oscilloscope tool as well as LabVIEW.

5.7

Position error

The motor position error, in other words the deviation between the commanded and actual motor
positions, may be read using the Read VI. As described previously, from the block’s context menu,
define the Select Method as Data and from the list of available inputs or outputs, select position error.

Note that the position error exceeded output that is included in the Read.Status method is not currently
supported.
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Home switch and the travel limit switches

The Motion I/O method of the Read block allows the user to monitor the status of the home switch and
the positive and negative travel limit switches.

Note that these input types must be explicitly configured in the drive’s digital I/O (X31). See the
IndraDrive Cs Project Planning Manual for more information. The default configuration is shown below.
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Further, the home switch is only read correctly provided the Enable Home Switch property for the
SoftMotion axis is set explicitly. Note that it is also recommended to set the Home Switch Stop Mode to
“Don’t Stop.”
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Establishing the position reference (“referencing”) of the axis

The Find Reference Move VI, found on the standard SoftMotion Express palette, provides the user with
various methods of establishing the drive’s position reference. Either of the travel limit switches, the
home switch, as well as the encoder’s internal reference mark, may be used to establish the position
reference. The drive’s current position may also be used (“absolute”). We treat each of these variants in
turn.

Reference Move – Forward Limit
To use the positive travel limit switch as the reference move target, add the Find Reference Move VI to
your block diagram. Right-click on the block and, from the available methods, select Forward Limit. Set
the Search Velocity as desired. When executed, the drive will move forward at the given search velocity
until the positive travel limit is reached, at which point the drive will stop and set the position reference 10.

Note that power must be supplied to the motor (see Power VI) prior to making the Find Forward Limit
Reference Move.
Be sure to properly configure the positive travel limit switch in the settings of the IndraDrive Cs. See
section Home switch and the travel limit switches.

10

The Bosch Rexroth SDI plugin, regardless of the reference method selected, does not support inputs Approach
Forward or Approach Velocity.
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Reference Move – Index
To establish the position reference at the index pulse or reference mark of the encoder, add the Find
Reference Move VI to your block diagram, selecting method Index. Configure the search direction and
search velocity as desired. Upon execution, drive will move in the given direction and at the given search
velocity until the encoder’s index pulse is detected, at which point the drive will stop and set the position
reference.

Note that power must be supplied to the motor (see Power VI) prior to making the Find Index Reference
Move. No additional hardware configuration is required.

Reference Move – Reverse Limit
To use the negative travel limit switch as the reference move target, add the Find Reference Move VI to
your block diagram. Right-click on the block and, from the available methods, select Reverse Limit. Set
the Search Velocity as desired. When executed, the drive will move backward at the given search
velocity until the negative travel limit is reached, at which point the drive will stop and set the position
reference.

Note that power must be supplied to the motor (see Power VI) prior to making the Reference Move.
Be sure to properly configure the negative travel limit switch in the settings of the IndraDrive Cs. See
section Home switch and the travel limit switches.
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Reference Move – Home switch
To use the home switch as the reference move target, add the Find Reference Move VI to your block
diagram. Right-click on the block and, from the available methods, select Home. Configure the block
inputs as required. Note that the block may be configure to look for either the rising or falling edge of the
home switch. . Upon execution, drive will move in the given direction and at the given search velocity
until the home switch is detected, at which point the drive will stop and set the position reference.

Note that power must be supplied to the motor (see Power VI) prior to making the Reference Move.
Be sure to properly configure the home switch in the settings of the IndraDrive Cs. See section Home
switch and the travel limit switches.
Reference Move – Absolute (Current position)
To reference the drive at its current position, use the Find Reference Move VI with method Absolute. This
method does not initiate any motion.

The SDI plugin currently configures the drive in such a way that it must be re-referenced each
time upon transitioning to operating mode (i.e. Scan Engine = active).
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Position capture (touch probe)

The SoftMotion position capture functionality described here requires that Probe 1 be correctly configured
in the settings of the IndraDrive Cs. See the IndraDrive Cs Project Planning Manual for more
information. Additional information is given in Section X.X.

High-speed position capture may be enabled in LabVIEW by calling the Position Capture VI with method
Enable>Single selected as active.

Once enabled, any values captured by the drive’s probe may be read using Read VI with method Capture
Data.

In addition, indication that a capture has in fact occurred is given by the Status method of Read VI using
output capture occurred.

Note that the position capture may be triggered by either the rising or falling edge of the associated probe
input. This is configured in the properties of the SoftMotion axis itself as shown below.
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To disable the position capture and reset the indicated capture status, call Position Capture again, this
time with Method Disable.
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